const regex = /([^=\s]+)\s*=\s*("[^"]+"|[^#]+?)\s*(?:$|#)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^=\\s]+)\\s*=\\s*("[^"]+"|[^#]+?)\\s*(?:$|#)', 'gm')
const str = `foo = "/usr/local/bin" # path string
eggs = [0, 1, 2, 3, 1]
spam = True # boolean
bar = 42
test = "this will be a big #fail"
path = "/home/tmp/valid#file#name" # comment`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}