$re = '/^(?!aem-Grid.*)/m';
$str = 'categoryteaser
image
aem-GridColumn
aem-GridColumn--default--12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);