import re
regex = re.compile(r"(?P<TYPE>^\.+\w*)+=+(?P<Programm>\S+)", flags=re.MULTILINE)
test_str = ("C:\\Users\\Игорь>Assoc\n"
".001=WinRAR\n"
".386=vxdfile\n"
".3ds=Photoshop.3DSFileType.150\n"
".3g2=WMP11.AssocFile.3G2\n"
".3gp=WMP11.AssocFile.3GP\n"
".3gp2=WMP11.AssocFile.3G2\n"
".3gpp=WMP11.AssocFile.3GP\n"
".7z=WinRAR\n"
".8ba=Photoshop.PlugIn\n"
".8bc=Photoshop.PlugIn\n"
".8be=Photoshop.PlugIn\n"
".8bf=Photoshop.PlugIn\n"
".8bi=Photoshop.PlugIn\n"
".8bp=Photoshop.PlugIn\n"
".8bs=Photoshop.PlugIn\n"
".8bx=Photoshop.PlugIn\n"
".8by=Photoshop.PlugIn\n"
".8li=Photoshop.PlugIn\n"
".AAC=WMP11.AssocFile.ADTS\n"
".abr=Photoshop.BrushesFile\n"
".acb=Photoshop.ColorBooks\n"
".accountpicture-ms=accountpicturefile\n"
".acf=Photoshop.CustomFilterKernel\n"
".acl=ACLFile\n"
".aco=Photoshop.SwatchesFile\n"
".act=Photoshop.ColorTableFile\n"
".acv=Photoshop.CurvesFile\n"
".ado=Photoshop.DuotoneSettingsFile\n"
".ADT=WMP11.AssocFile.ADTS\n"
".ADTS=WMP11.AssocFile.ADTS\n"
".ahs=Photoshop.HalftoneScreens\n"
".ahu=Photoshop.HueSatFile\n"
".aif=WMP11.AssocFile.AIFF\n"
".aifc=WMP11.AssocFile.AIFF\n"
".aiff=WMP11.AssocFile.AIFF\n"
".alv=Photoshop.LevelsFile\n"
".amp=Photoshop.ArbitraryMapFile\n"
".ams=Photoshop.MonitorSetupFile")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")