package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(\w+)`)
var str = `Lorem`
var substitution = "Lorem $1 AAA \$1 BBB $1 Lorem"
fmt.Println(re.ReplaceAllString(str, substitution))
}