$re = '/(\w+)/s';
$str = 'Lorem';
$subst = "Lorem $1 AAA \$1 BBB $1 Lorem";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;