using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/(.*:.*@)?[^\.:]+(\.[^\.:]+){1,2}(\:\d+)?[^:]+$";
string input = @"http://io:tu@was.as.ds:12/asd
http://was.as.ds:12/asd
http://io:tu@was.as.ds/asd
http://io:tu@was.as.com
https://io:tu@was.as.ds/asd
httpp://io:tu@was.as.ds/asd
http:/io:tu@was.as.ds/asd
http://io:tu#was.as.ds/asd
http://io:tu@was.ds
https://was.ds
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}