import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/(.*:.*@)?[^\\.:]+(\\.[^\\.:]+){1,2}(\\:\\d+)?[^:]+$";
final String string = "http://io:tu@was.as.ds:12/asd\n"
+ "http://was.as.ds:12/asd\n"
+ "http://io:tu@was.as.ds/asd\n"
+ "http://io:tu@was.as.com\n"
+ "https://io:tu@was.as.ds/asd\n"
+ "httpp://io:tu@was.as.ds/asd\n"
+ "http:/io:tu@was.as.ds/asd\n"
+ "http://io:tu#was.as.ds/asd\n"
+ "http://io:tu@was.ds\n"
+ "https://was.ds\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}