import Foundation
let pattern = #"^https?:\/\/(.*:.*@)?[^\.:]+(\.[^\.:]+){1,2}(\:\d+)?[^:]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
http://io:tu@was.as.ds:12/asd
http://was.as.ds:12/asd
http://io:tu@was.as.ds/asd
http://io:tu@was.as.com
https://io:tu@was.as.ds/asd
httpp://io:tu@was.as.ds/asd
http:/io:tu@was.as.ds/asd
http://io:tu#was.as.ds/asd
http://io:tu@was.ds
https://was.ds
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)