const regex = /<a.+title="(.*Zennolab.*?)">/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.+title="(.*Zennolab.*?)">', 'g')
const str = `border="0" ></div><a href="http://domain.com/" title="Текст заголовка Zennolab">
border="0" ></div><a href="http://domain.com/" title="Текст Zennolab заголовка">
border="0" ></div><a href="http://domain.com/" title="Zennolab">
border="0" ></div><a href="http://domain.com/" title="Текст заголовка">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}