$re = '/^domressult:\s+\"([^\"]+?)(\".*)/';
$str = 'domressult: "-d aaa -d bbb -d CCC" # coment';
$subst = "domressult: \"\1 -d bbb\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;