re = /[\p{L}\p{N}-_'.@]+|"\w+"/m
str = 'higgs-boson
fred\'s kitchen
2001
@dragonflyeye.net
Ulyssus\'
"af"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end