re = /dat(?:(?!dat).)*?wy.*?(\d{1,4}([\/ .-])\d{1,2}\2\d{1,4})/mi
str = 'abc18.Dat wy.03/12/2019FFF*Dato dost2009/03/03**data wy2020-09-30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end