$re = '/(?<v1>.+:\\\\.+?\\\\(.+?)\\\\.+)/m';
$str = 'c:\\ABC\\DEF\\LOGS\\1.LOG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);