package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)aaa|bbb|ccc`)
var str = `AAA
aaa
BBB
bbb
CCC
ccc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}