#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!Hello\b)\S(?:.*\S)?$"
Local $sString = "test" & @CRLF & _
" test" & @CRLF & _
"test " & @CRLF & _
"Hello" & @CRLF & _
" Hello " & @CRLF & _
" Hello" & @CRLF & _
"Hello " & @CRLF & _
"Hell" & @CRLF & _
"H" & @CRLF & _
"" & @CRLF & _
"thisis a test" & @CRLF & _
"Hello, this is a test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")