$re = '/^(?!Hello\b)\S(?:.*\S)?$/m';
$str = 'test
test
test
Hello
Hello
Hello
Hello
Hell
H
thisis a test
Hello, this is a test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);