re = /^(?!Hello\b)\S(?:.*\S)?$/m
str = 'test
test
test
Hello
Hello
Hello
Hello
Hell
H
thisis a test
Hello, this is a test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end