re = /(?<=[^\/])\/(?=[^\/])([\w\s\S]*)$/
str = 'https://documentosavanzopr.s3.amazonaws.com/1090525908/3/Requests/13645/paymentSupport-a3a27d291f20b743.pdf'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end