using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<name>\w+):[a-zA-Z<>]*\[?(?P<shape>(?:(?:\w*)\s*,?)*)\]";
string input = @"a: [1, 2, 3]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}