# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:DE(?:\s*\d){20}|AT(?:\s*\d){18})\b(?!\s*\d)"
test_str = ("################## Germany IBAN ##################\n"
"DE59290501010001149590\n"
"DE62500105179628448387\n"
"DE55500105172374652131\n"
"DE50500105176152274153\n\n"
"DE 0712 3412 3412 3412 3412\n"
"DE07 1234 1234 1234 1234 12\n"
"DE07 1234 1234 1234 123412\n\n"
"Mashine friendly DE07123412341234123412 style\n"
"This format DE07 1234 1234 1234 1234 12 is given by DIN\n"
"Human DE07 1234 1234 1234 123412 readable\n"
"Not good DE07 12341234 1234123412 readable\n\n"
"################## Austrian IBAN ##################\n"
"AT59290501010001149590\n"
"AT62500105179628448387\n"
"AT55500105172374652131\n"
"AT50500105176152274153\n\n"
"AT 0712 3412 3412 3412 3412\n"
"AT07 1234 1234 1234 1234 12\n"
"AT07 1234 1234 1234 123412\n\n"
"Mashine friendly AT07123412341234123412 style\n"
"This format AT07 1234 1234 1234 1234 12 is given by DIN\n"
"Human AT07 1234 1234 1234 123412 readable\n"
"Not good AT07 12341234 1234123412 readable\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.