#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bfeature\.?\w+(?!(ONLY|PRACA))\b"
Local $sString = "feature.Agencyjna_ONLY" & @CRLF & _
"feature.UoP" & @CRLF & _
"feature.UoD" & @CRLF & _
"feature.PRACA" & @CRLF & _
"featurePRACA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")