import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bfeature\\.?\\w+(?!(ONLY|PRACA))\\b";
final String string = "feature.Agencyjna_ONLY\n"
+ "feature.UoP\n"
+ "feature.UoD\n"
+ "feature.PRACA\n"
+ "featurePRACA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}