re = /\bfeature\.?\w+(?!(ONLY|PRACA))\b/m
str = 'feature.Agencyjna_ONLY
feature.UoP
feature.UoD
feature.PRACA
featurePRACA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end