const regex = /(?<!:):(?!:)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!:):(?!:)', 'g')
const str = `/path/to/file/namespace/filename:line_number:error message Namespace\\ClassName::method().`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);