package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<a1>PREM)\|(?<a2>.{4})\|(?<a3>.{2})\|(?<a4>.{2})\|(?<a5>.+)`)
var str = `PREM|E001|E5|RG|ACCOUNTSPAYABLE@THMGT.COM`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}