use strict;
my $str = '$ $ $ +YBL PATAUDI CHOWK \\ $
$ $ -ATM CASH 83181 + MAIN BHAWANA ROAD NEW DELHI $
$ $ [5839/P1TNDE06/+RAGHUBARPURA $
$ MAXIMUMOUTFITS PRIVATE LIMITED } $ ATDELHIIN- $ $ /5631 $
$ ATM CASH-N4077800-+SPRINGFIELDCOLONYFFAR IDABADHRIN-04/06/18 $ /5631 ( $ $ VERIFICATION $"))';
my $regex = qr/(?:[+@:]|\bAT(?!M))\s*([A-Z]+(?:\s+[A-Z]+)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}