import re
regex = re.compile(r"(?:[+@:]|\bAT(?!M))\s*([A-Z]+(?:\s+[A-Z]+)*)", flags=re.MULTILINE)
test_str = ("$ $ $ +YBL PATAUDI CHOWK \\ $\n"
"$ $ -ATM CASH 83181 + MAIN BHAWANA ROAD NEW DELHI $\n"
"$ $ [5839/P1TNDE06/+RAGHUBARPURA $\n"
"$ MAXIMUMOUTFITS PRIVATE LIMITED } $ ATDELHIIN- $ $ /5631 $\n"
"$ ATM CASH-N4077800-+SPRINGFIELDCOLONYFFAR IDABADHRIN-04/06/18 $ /5631 ( $ $ VERIFICATION $\"))")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")