# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Z]\d\d[.]?\d?\d?$"
test_str = ("D99\n"
"M00.0\n"
"M01.6\n"
"J98.3\n"
"T05.0\n"
"D96.81\n"
"M68.20\n"
"9D.0\n"
"6G\n"
"7H.\n"
"M96.811\n"
"J234.82\n"
"G687.1\n"
"GU87.11\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.