$re = '/(.+?) & (.+?) & (.*)/m';
$str = 'Dreamy & Claire Willis & Daniel Kandi
Earth & Wind & Fire
Jimmy & James & The Tempos
Don\'t work for
Bob & Graeme & Sean & Greg
Legrand & Charrie & Aulivier & Danot
Jimmy Page & Robert Plant';
$subst = "$1 & $3 & $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;