import Foundation
let pattern = #"((\d*,*\d*\d)\\)|(\d*,\d*)|((\d*)\/)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1,258\xa0sq\xa0mi (3,260\xa0km2)
45\xa0sq\xa0mi (120\xa0km2) \xa03.6%
234,878
45\xa0sq\xa0mi (120\xa0km2) \xa03.6%
194/sq\xa0mi (75/km2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)