package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]+(?:-[a-zA-Z]+)*$`)
var str = `John-Doe
John-Doe-Junior
-John-Doe
John-Doe-
-John-Doe-
John--Doe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}