const regex = new RegExp('(\\d+\\s?)(days|weeks|hours)(.*)', 'gm')
const str = `2 hours`;
const subst = `in \g<0>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);