use strict;
my $str = '2 hours';
my $regex = qr/(\d+\s?)(days|weeks|hours)(.*)/mp;
my $subst = 'in \\g<0>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";