re = /(?<![\\])\"([^\"]*)(?<!\\)(?<![\\])\"/m
str = '"test1"" test2 "\\"test \\""test 3"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end