#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bFOO\b(?![^[\]]*(?:\[\[[^[\]]*]][^[\]\n]*)*]])"
Local $sString = "Should match the following" & @CRLF & _
"lorem ipsum FOO dolor" & @CRLF & _
"lorem ipsum FOO dolor [[amet]]" & @CRLF & _
"[[lorem]] ipsum FOO dolor [[sit]] amet" & @CRLF & _
"" & @CRLF & _
"Should NOT match the following" & @CRLF & _
"lorem ipsum [[FOO]] dolor" & @CRLF & _
"lorem [[ipsum FOO dolor]] sit amet" & @CRLF & _
"lorem [[ipsumFOOsolor]] sit amet" & @CRLF & _
"[[lorem]]" & @CRLF & _
"[[ipsum-FOO&dolor-sit.pdf#page=130]]" & @CRLF & _
"lorem ipsumFOOsolor sit amet" & @CRLF & _
"" & @CRLF & _
"FOO should be matched below but is not because the double-brackets are not balanced." & @CRLF & _
"lorem FOO [[ipsumFOOsolor]] sit ]] amet"
Local $sSubst = "BAZ"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)