#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(this is) test (?<test>testValue)"
Local $sString = "this is test testValue"
Local $sSubst = "$1 test <!<mode:\\U>%&${test}&%>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)