import Foundation
let pattern = #"(this is) test (?<test>testValue)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"this is test testValue"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 test <!<mode:\\U>%&${test}&%>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)