package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+(?:[^+\n]*\+){2}`)
var str = `+1a
+1a +2
+1a +2 +3
+1a +2 +3 +4
+1a +2 +3 +4 +5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}