use strict;
my $str = '# without scope
feat: add REST endpoint /my-app/api/versions
fix: change git commit username
style: set indentation to 4 spaces
docs: explain new configuration preset
# with scope
feat(backend): add REST endpoint /my-app/api/versions
fix(default): change git commit username
style(npm): set indentation to 4 spaces
docs(terraform): explain new configuration preset
# smartcommit without scope
[CORE-1234 /fixed] feat: add REST endpoint /my-app/api/versions
[HDEFECT-1234 /fixed] fix: change git commit username
[HDEFECT-1234 /fixed] style: set indentation to 4 spaces
[HDEFECT-1234 /fixed] docs: explain new configuration preset
# smartcommit with scope
[CORE-1234 /fixed] feat(backend): add REST endpoint /my-app/api/versions
[HDEFECT-1234 /fixed] fix(default): change git commit username
[HDEFECT-1234 /fixed] style(npm): set indentation to 4 spaces
[HDEFECT-1234 /fixed] docs(terraform): explain new configuration preset
# not match - wrong smart commit
[core-1234 /fixed] feat(backend): add REST endpoint /my-app/api/versions
[hdefect-1234 /fixed] fix(default): change git commit username
[hdefect-1234 /fixed] style(npm): set indentation to 4 spaces
[hdefect-1234 /fixed] docs(terraform): explain new configuration preset
# not matched - use /fixed in title
[CORE-1234 /fixed] feat(backend): add REST endpoint /my-app/api/versions /fixed
[HDEFECT-1234 /fixed] fix(default): change git commit /fixed username
[HDEFECT-1234 /fixed] style(npm): set /FIXED indentation to 4 spaces
[HDEFECT-1234 /fixed] docs(terraform): /fixed explain new configuration preset
';
my $regex = qr/^(?:\[[A-Z]*-\d* \/fixed\] )?(?<type>\w*)(?:\((?<scope>[\w$.\-*\/ ]*)\))?: (?<subject>(?:.(?!(?i)\/fixed))*)$/mp;
my $subst = '$type $scope $subject';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";