import Foundation
let pattern = #"^(?:.*?\x7C){14}(?'champs1'.*?)\x7C(?:.*?\x7C){6}(?'champs2'.*?)\x7C(?'champs3'.*?)\x7C"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1906823505|BPA|CORENC-BPAUR0133|LR35788G|LEONETTI CATHERINE|04.76.88.14.14||INT|MG_ENS_010002|Ensemble Chauffage-Climatisation||MNT|MG116|05/06/2019 17:36:00|06/06/2019 10:36:00|4|FR|05/06/2019 16:36:00|BPA|CORENC-BPAUR0133|LR35788G|BPAURA-ENGIE LOIR|ENGIE COFELY LOIRE|0|||313|002|A1 - ESPACE 4|0|BP AUVERGNE RHONE ALPES (CORENC-BPAUR0133)|2 AVENUE DU GRESIVAUDAN||38700|CORENC|0438884619||||1906823505|merci d'intervenir pour rétablir la clim à l'agence"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)