#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:pass|password)\s*[:=;,]\s*(?!\s{0,}function)(\S*)"
Local $sString = "password = potato123! found, is ok" & @CRLF & _
"$dbpass= train123; = found, is ok" & @CRLF & _
"pass:function($pass); = not found, is ok" & @CRLF & _
"$dbpassword= function('dontfindme'); = found, should not be found" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")