const regex = /(?:pass|password)\s*[:=;,]\s*(?!\s{0,}function)(\S*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:pass|password)\\s*[:=;,]\\s*(?!\\s{0,}function)(\\S*)', 'g')
const str = `password = potato123! found, is ok
\$dbpass= train123; = found, is ok
pass:function(\$pass); = not found, is ok
\$dbpassword= function('dontfindme'); = found, should not be found
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}