$re = '/(?:pass|password)\s*[:=;,]\s*(?!\s{0,}function)(\S*)/';
$str = 'password = potato123! found, is ok
$dbpass= train123; = found, is ok
pass:function($pass); = not found, is ok
$dbpassword= function(\'dontfindme\'); = found, should not be found
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);