# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b'\b(*SKIP)(*FAIL)|'/"/gm;t' <<< "'I don't go to work tomorrow 2'5'"