const regex = /\b'\b(*SKIP)(*FAIL)|'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\'\\b(*SKIP)(*FAIL)|\'', 'gm')
const str = `'I don't go to work tomorrow 2'5'`;
const subst = `"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);