use strict;
my $str = '\'I don\'t go to work tomorrow 2\'5\'';
my $regex = qr/\b'\b(*SKIP)(*FAIL)|'/mp;
my $subst = '"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";