re = /\b'\b(*SKIP)(*FAIL)|'/m
str = '\'I don\'t go to work tomorrow 2\'5\''
subst = '"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result