package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+\s*[+-]\s*\d+\s*=\s*\d+$`)
var str = `2 2 + 2
2 +2=4
3 - 2=1
2 4-2=6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}