#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\s*([+-]\s*\d+\s*)*=\s*\d+$"
Local $sString = "2 2 + 2" & @CRLF & _
"2 +2=4" & @CRLF & _
"3 - 2=1" & @CRLF & _
"2 4-2=6" & @CRLF & _
"2 + 2 + 4 +6 -3=2" & @CRLF & _
"2=2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")