// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+\s*([+-]\s*\d+\s*)*=\s*\d+$").unwrap();
let string = "2 2 + 2
2 +2=4
3 - 2=1
2 4-2=6
2 + 2 + 4 +6 -3=2
2=2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}